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Аннотация 

Цифровая революция затронула методологическую и методическую базы 

всех проводимых в настоящее время научных исследований. Интерес к созда-

нию спектральных библиотек во всём мире увеличивается, так как спектраль-

ный анализ может быть использован в качестве ёмкого и не деструктивного ме-

тода, результаты которого коррелируют со многими почвенными свойствами. 

Спектральная библиотека (SSL - Soil Spectra libraries) представляет собой базу 

данных, в которой представлены эталонные образцы спектров почв с описани-

ем их химических и физических свойств.  
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Abstract 

The digital revolution has affected the methodological and methodological bases 

of all ongoing scientific research. Interest in the creation of spectral libraries around 

the world is increasing, since spectral analysis can be used as a capacious and non-

destructive method, the results of which correlate with many soil properties. The Soil 

Spectra Libraries (SSL) is a database that contains reference samples of soil spectra 

with a description of their chemical and physical properties. 
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Введение. Современный этап развития почвоведения связан с формирова-

нием баз данных, которые позволяют систематизировать как уже накопленные 

ранее сведения, так и организовать сбор новой информации по установленным 

протоколам и единой схеме. Интерес к созданию спектральных библиотек во 

всем мире увеличивается, что связано как с развитием дистанционных методов 

исследования почв, так и с привлекательностью спектрального анализа в каче-

стве не деструктивного, информационно и ёмкого метода, результаты которого 

коррелируют со многими почвенными свойствами.  

Примером такой базы данных служит европейская спектральная библиотека 

(The European spectral library) LUCAS, которая содержит данные 23 стран Евро-

пы о спектрах более, чем 20 тыс. образцов верхнего слоя почвы и связанных с 

ними основными почвенными свойствами. Данные в этой спектральной биб-

лиотеке получены за два периода: 2009 и 2015 годы [16]. Это позволяет прово-
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дить анализ с учетом времени и регистрировать тенденции в изменении состоя-

ния почвенных свойств. Эти опубликованные данные находятся в открытом до-

ступе и представляют возможность работать с ними зарегистрированным поль-

зователям. 

Анализ данной библиотеки проводится по трем главным направлениям. 

Первое – определение математических методов (моделей), наиболее эффектив-

ных, с точки зрения предсказательной способности почвенных свойств, для 

глобального массива данных. Второе – установить, насколько будут меняться 

модели при переходе от глобальных данных к локальным. Третье направление, 

специфичное для России, связано с тем, что в нашей стране в результате много-

летней работы почвоведов накопилось большое количество изображений поч-

венных спектров отражения, которые удалось собрать в базу данных “Спектры 

отражения и цифровые показатели цвета почв” [4]. Первые полученные резуль-

таты анализа данных показали, что применение некоторых показателей цветно-

сти, не входящих пока в международный научный оборот, позволяет проводить 

диагностику почвенных свойств с большей эффективностью, чем применяемые 

в настоящее время стандартные показатели. 

Материалы и методы. На первом этапе производилась предварительная 

обработка графических файлов. Сканированные или сфотографированные 

изображения спектральных кривых подвергали предварительной очистке, с це-

лью получения только одного изображения спектра в файле *.bmp, для чего ис-

пользовали программу Paint.Net. Полученное изображение сохраняли в форма-

те *.bmp с размерами, точно соответствующими внутреннему полю первона-

чального файла, ограниченному осями X (длина волны) и Y (спектральное от-

ражение, %). 

 

Рисунок 1 – Изображение до (a) и после обработки в графическом редакторе (б) 

Рисунок сохраняли с новым названием. Для примера, рисунок 1 имел назва-

ние 00079_00_50_400_750.bmp. Формирование названия файла соответствовало 

алгоритму, в соответствии с которым первые 5 знаков (00079) обозначали уни-

кальный номер спектра, следующие 4 знака – точки начала (00) и конца коор-

динат (50) по оси Y, затем начала (400) и конца (750) координат по оси X (дли-

на волны).  
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Информацию о каждом спектре заносили в таблицу (таблица 1, фрагмент). 

Таким образом, формировали два потока информации – графический (файл 

в формате *.bmp) и тематический (таблица в *.xls), связанные друг с другом по 

уникальному названию файла. 

Таблица 1 – Информация о спектральных кривых, вошедшая в базу данных 

(фрагмент) 

Файл 
Источник  
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0007

9_00

_50_

400_

750.b

mp 

Д. С. Орлов и 

др. Почвенно-

экологический 

мониторинг.  

1994 

131 10 1 Гумусный 

горизонт 1 

- Спектро-

фотометр 

Соби-

раю-

щая 

сфера 

0008

0_00

_50_

400_

750.b

mp 

Д. С. Орлов и 

др. Почвенно-

экологический 

мониторинг.  

1994 

131 10 2 Гумусный 

горизонт 2 

- Спектро-

фотометр 

Соби-

раю-

щая 

сфера 

0008

1_00

_50_

400_

750.b

mp 

Д. С. Орлов и 

др. Почвенно-

экологический 

мониторинг.  

1994 

131 10 3 Гумусный 

горизонт 3 

- Спектро-

фотометр 

Соби-

раю-

щая 

сфера 

0008

2_00

_70_

400_

750.b

mp 

Д. С. Орлов и 

др. Почвенно-

экологический 

мониторинг.  

1994 

131 11 1 Осветленный 

горизонт 1 

- Спектро-

фотометр 

Соби-

раю-

щая 

сфера 

0008

3_00

_70_

400_

750.b

mp 

Д. С. Орлов и 

др. Почвенно-

экологический 

мониторинг.  

1994 

131 11 2 Осветленный 

горизонт 2 

- Спектро-

фотометр 

Соби-

раю-

щая 

сфера 

0008

4_00

_70_

400_

750.b

mp 

Д. С. Орлов и 

др. Почвенно-

экологический 

мониторинг.  

1994 

131 11 3 Осветленный 

горизонт 3 

- Спектро-

фотометр 

Соби-

раю-

щая 

сфера 
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0008

5_00

_50_

400_

750.b

mp 

Д. С. Орлов и 

др. Почвенно-

экологический 

мониторинг.  

1994 

132 12 1 Ожелезненный 

горизонт 1 

- Спектро-

фотометр 

Соби-

раю-

щая 

сфера 

0008

6_00

_50_

400_

750.b

mp 

Д. С. Орлов и 

др. Почвенно-

экологический 

мониторинг.  

1994 

132 12 2 Ожелезненный 

горизонт 2 

- Спектро-

фотометр 

Соби-

раю-

щая 

сфера 

0008

7_00

_50_

400_

750.b

mp 

Д. С. Орлов и 

др. Почвенно-

экологический 

мониторинг.  

1994 

132 12 3 Ожелезненный 

горизонт 3 

- Спектро-

фотометр 

Соби-

раю-

щая 

сфера 

На втором этапе проводилось векторно-цифровое преобразование изобра-

жений в программе SAGA GIS. Целью данного этапа было получение цифровой 

информации о спектре в формате *.csv. Каждая таблица содержала данные в 3 

полях: n – номер точки на графике; x – длина волны; y – отражение, %. Процесс 

обработки в геоинформационной системе SAGA GIS [13] был подразделен на 

несколько этапов, которые будут последовательно описаны на примере файла 

00079_00_50_400_750.bmp. 

1. В результате открытия файла в программе образуется растровое изобра-

жение в виде грида с расширением *.sgrd - внутренний формат растров в SAGA 

(00079_00_50_400_750.sgrd). 

2. Поводится векторизация растрового изображения (Shapes -> Shapes -> 

Grid Tool -> Vectorization -> Grid Values to Points). В результате образуется век-

торный файл формата *.shp. Так как этот этап в преобразованиях промежуточ-

ный, файлу присваивается название с префиксом temp (temp_GV1.shp). Данный 

файл состоит из совокупности белых (фон) и черных (полезный сигнал – спек-

тральные значения) точек. Они различаются по полю атрибута (Z) – это значе-

ние, извлеченное из грида. У белых точек Z>0, у черных точек Z=0. 

3. На следующем этапе в файле temp_GV1.shp выделяются все фоновые 

точки, у которых Z>0: Shapes -> Selection -> Select by Attributes (Numerical 

Expression) -> Z > 0. Затем происходит удаление точек фона: Shapes -> Selection 

-> Delete Selection from Shapes Layer. 

4. Далее в файле temp_GV1.shp проводится преобразование значений кон-

туров спектральных кривых по координате Х с помощью вычисления по формуле 

,   (1) 

где 400 – начальная координата X (длина волны); X – текущая координата; 

750 – конечная координата X; 990 – ширина файла *.bmp в пикселях. 
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В результате создаются новые данные по точкам 02. Grid Values [Nodes] и 

файл temp_GV2.shp. Изначальные данные по точкам 01. Grid Values [Nodes] мо-

гут быть по усмотрению удалены. 

5. Затем в файле temp_GV2.shp проводится преобразование значений конту-

ров спектральных кривых по координате Y с помощью вычисления по формуле 

,    (2) 

где 0 – начальная координата Y (длина волны); Y – текущая координата; 50 – 

конечная координата Y; 577 – ширина файла *.bmp в пикселях. 

В результате вычеслений создаются новые данные по точкам 05. Grid Values 

[Nodes] и файл temp_GV5.shp. Предыдущие данные по точкам 02. Grid Values 

[Nodes] могут быть по усмотрению удалены. 

6. Потом в файле temp_GV5.shp проводится округление значений контуров 

спектральных кривых по координате X с помощью вычисления по формуле 

,      (3) 

где int – функция возвращающая целочисленное значение дробной переменной; 

X – текущая координата; 

В процессе вычисления создаются новые данные по точкам 07. Grid Values 

[Nodes] и файл temp_GV7.shp. Предыдущие данные по точкам 05. Grid Values 

[Nodes] могут быть по усмотрению удалены. 

7. Далее в файле temp_GV7.shp проводится аггрегация значений точек спек-

тральных кривых с помощью аттрибутов по полю 1 и статистическому полю 2: 

Table -> Calculus -> Aggregate Values by Attributes [Table] по координате Х. В 

полях отмечается только значение среднего и создается новая таблица 01. Grid 

Values [Nodes] [Aggregated: X]. Потом предыдущие данные по точкам 07. Grid 

Values [Nodes] могут быть по усмотрению удалены. Затем таблица переимено-

вывается в Spec_01nm: Window -> Show Object Properties Window и сохраняется 

в формате dbf. Результатом этого этапа является получение цифровой инфор-

мации о спектре объекта с разрешением по длине волны 1 нм. 

8. Затем на основе таблицы Spec_01nm.dbf создаётся новая таблица 

Spec_10nm.dbf: Shapes -> Table -> Field Calculator [Shapes] по столбцу Х10. По-

том новая созданная таблица Spec_01nm.dbf переименовывается в 

Spec_10nm.dbf: Window -> Show Object Properties Window. Далее проводится 

аггрегация значений таблицы с помощью аттрибутов, при этом происходит до-

бавление столбца Х10, по статистическому столбцу Y: Table -> Calculus -> Ag-

gregate Values by Attributes [Table]. В полях отмечается только значение средне-

го и создается новая таблица 06. Spec_10nm.dbf [Aggregated: X10]. Потом 

предыдущая таблица 05. Spec_10nm.dbf может быть по усмотрению удалена. И 

далее название таблицы 06. Spec_10nm.dbf [Aggregated: X10] сокращается до 

06. Spec_10nm.dbf: Window -> Show Object Properties Window и сохраняется в 

формате dbf с заменой предыдущей таблицы с тем же названием. Результатом 

этого этапа является получение цифровой информации о спектре объекта с раз-

решением по длине волны 10 нм. 
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Заключение. В настоящее время в научной литературе сложилась противо-

речивая ситуация. С одной стороны, существует огромное количество инфор-

мации, которую трудно бывает не только осмыслить, но даже прочитать. С дру-

гой стороны, некоторые, известные ранее факты и закономерности, или забыты, 

или исключены из научного оборота, поскольку приоритет отдается англоязыч-

ным публикациям, а их авторы практически не знакомы с русскоязычной лите-

ратурой. Поэтому происходит “переоткрытие” того, что было открыто ещё в 60-

80-ые годы прошлого века. 

Показательна в этом отношении работа китайских исследователей, которые 

предложили в 2010 году подход, который они назвали “схема динамической 

обратной связи”. Они полагали, что разрабатывали новую переменную среды, 

которая изменяется в зависимости от пространственного изменения почвы. В 

их исследовании изучалась идея о том, что изменяющиеся типы поверхности 

земли, такие как те, которые ежедневно снимаются с помощью изображений 

дистанционного зондирования в течение короткого периода (6–7 дней) после 

сильного дождя, могут использоваться для дифференциации типов почвы. Для 

измерения динамики обратной связи они использовали спектральное расхожде-

ние информации (spectral information divergence, SID). Результаты показали, что 

существует значительная разница в значениях SID между парами пикселей в 

одной и той же подгруппе почвы и в разных подгруппах. Это указывало на то, 

что области с разными типами почв (уровень подгруппы) демонстрировали су-

щественно разные динамические схемы обратной связи, а области в пределах 

одного и того же типа почвы имеют сходные динамические схемы обратной 

связи. Также было обнаружено, что чем больше сходных типов почв, тем боль-

ше сходных моделей обратной связи. Авторы считали, что полученные резуль-

таты могут привести к разработке нового экологического ковариата, который 

может быть использован для повышения точности картирования почв в районах 

с низким рельефом [25]. 

Обобщенные формы связи коэффициента яркости ρ поверхности почвы в 

оранжево-красной части спектра с влажностью поверхностного горизонта почв 

w были описаны Б.В. Виноградовым еще в 80-ые годы прошлого века [1]. Из-

менение яркости пикселей на аэрокосмическом изображении при иссушении 

почвы полностью соответствует термину «схема динамической обратной свя-

зи» Zhu с соавторами [25]. Для измерения динамики обратной связи Виногра-

дов использовал эмпирические уравнения, которые давали возможность с вы-

сокой точностью предсказывать гранулометрический состав почв по формам 

математически описанных кривых. На этом примере видно, что работа 2010 го-

да «переоткрывает» найденные ранее закономерности, а также уходит в сторо-

ну их математического формального описания, не используя функциональные 

зависимости.  

Созданная нами база данных поможет избежать именно такой ситуации, по-

скольку объединяет в себе «старые» и «новые» знания и дает возможность не 

потерять ранее найденные закономерности.  
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Выводы: 

1. Собрана информация по спектральным характеристикам 223 образцов 

почв из 22 литературных источников. 

2. Проведена графическая обработка и векторно-цифровое преобразование 

изображений в программе SAGA GIS. 

3. Для всех спектров собраны метаданные: таксономическая принадлеж-

ность, почвенные свойства в систему таблиц. 

4. Проведено объединение векторизованных графических материалов с 

данными по спектрам отражения в цифровом формате. 

5. Создана база данных, которая включает 705 спектров отражения, сведе-

ния о принадлежности образцов к 19 группам генетических горизонтов. 556 

спектров имеют таксономическую характеристику на уровне типа, 488 - подти-

па, 416 – разряда (почвообразующая порода). Для 349 образцов указан 

гранулометрический состав. 

6. Показана возможность использования базы данных для сравнительной 

характеристики цветовых различий на уровне спектров отражения и цветовых 

показателей основных типов почв, в том числе с привлечением цветовых коэф-

фициентов, разработанных ранее в отечественном почвоведении. 
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Аннотация 

Применение современных геоинформационных технологий является важ-

ным и актуальным направлением исследований. Они позволяют создавать ин-
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